Files cannot be downloaded from multiple requests at once - All Regions

Incident Report for Suralink

Resolved

The issue preventing files from being downloaded from multiple requests has been resolved.
Posted Sep 09, 2025 - 15:55 MDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 09, 2025 - 15:34 MDT

Identified

We have identified the issue that is preventing files from downloading when multiple requests have been selected. Our engineering team is working on a resolution, and we will provide an update when we have more information.
Posted Sep 09, 2025 - 13:49 MDT

Investigating

We are investigating an issue that is preventing files from downloading when attempting to download from multiple requests. Our engineering teams are actively working to resolve the issue as quickly as possible.

Downloading files from individual requests is working as expected.

We will provide an update as soon as we have more information.
Posted Sep 09, 2025 - 12:30 MDT
This incident affected: United States (File Uploads and Downloads), Canada (File Uploads and Downloads), and Europe (File Uploads and Downloads).