File Upload and Download - US Region

Incident Report for Suralink

Resolved

This incident has been resolved.
Posted Feb 27, 2026 - 15:14 MST

Monitoring

We have implemented a fix that was preventing files from uploading and downloading in the US region, and are monitoring to ensure full resolution.
Posted Feb 27, 2026 - 15:01 MST

Investigating

We are investigating an issue that is preventing files from uploading and downloading in the US region. Our engineering teams are actively working to resolve the issue as quickly as possible. We will provide an update as soon as we have more information.
Posted Feb 27, 2026 - 14:50 MST
This incident affected: United States (File Uploads and Downloads).