Request Comments not saving or loading - US Region

Incident Report for Suralink

Resolved

The issue that was preventing request comments from loading or saving has been resolved.
Posted Feb 24, 2026 - 10:41 MST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 24, 2026 - 10:31 MST

Investigating

We are investigating an issue with the Suralink web application affecting users in the US region, where request comments may not be loading or saving. Our engineering teams are actively working to resolve the issue as quickly as possible. We will provide an update as soon as we have more information.
Posted Feb 24, 2026 - 10:14 MST
This incident affected: United States (Request List (Engagements)).