Login Issues - All Regions

Incident Report for Suralink

Resolved

This incident has been resolved.
Posted Apr 22, 2025 - 13:30 MDT

Update

Issue has been addressed and team will monitor
Posted Apr 22, 2025 - 13:30 MDT

Identified

We have identified the issue that is causing slowness when logging into the application, and is preventing some users from logging in. Our engineers are working on a resolution, and we will provide an update when we have more information.
Posted Apr 22, 2025 - 13:02 MDT

Investigating

We are investigating an issue that is causing slowness when logging into the application. Our engineering teams are actively working to resolve the issue as quickly as possible. We will provide an update as soon as we have more information.
Posted Apr 22, 2025 - 12:34 MDT
This incident affected: United States (Suralink Web Application), Canada (Suralink Web Application), and Europe (Suralink Web Application).