File Upload and Download - US Region
Incident Report for Suralink
Resolved
This incident has been resolved.
Posted Sep 17, 2024 - 10:33 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 17, 2024 - 10:00 MDT
Identified
We have identified the issue with file uploads and downloads, and are implementing a fix.
Posted Sep 17, 2024 - 09:55 MDT
Investigating
We are investigating an issue with uploading and downloading files in the US region. Our engineering teams are actively working to resolve the issue as quickly as possible. We will provide an update as soon as we have more information.
Posted Sep 17, 2024 - 09:50 MDT
This incident affected: United States (File Uploads and Downloads).