Degraded performance in Workpaper Suite, Assessment Hub, and Cloud Testing Suite - US Region

Incident Report for Suralink

Resolved

The issue that was causing degraded performance in Workpaper Suite, Assessment Hub, and Cloud Testing Suite has been resolved.
Posted Jul 09, 2026 - 14:15 MDT

Monitoring

We have implemented a fix for the issues causing performance degradation in Workpaper Suite, Assessment Hub, and Cloud Testing Suite, and our teams are monitoring to ensure full resolution.
Posted Jul 09, 2026 - 14:07 MDT

Identified

We have identified an issue that is preventing the Intelligence features in Workpaper Suite, Ask Anything in Assessment Hub, and Cloud Testing Suite from working as expected. Our engineering team is actively working to resolve this, and we'll provide an update when we have more information to share.
Posted Jul 09, 2026 - 13:57 MDT
This incident affected: United States (Workpaper Suite, Assessment Hub, Cloud Testing Suite).