Slow Response Time - US Region

Incident Report for Suralink

Resolved

This incident has been resolved.
Posted Jul 29, 2024 - 13:05 MDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 29, 2024 - 09:54 MDT

Identified

We have identified the cause of the application slowness in the US region, and are implementing a fix.
Posted Jul 29, 2024 - 08:48 MDT

Investigating

We are experiencing slow response times within the Suralink web application that is affecting the US region. Our engineering teams are actively working to resolve the issue as quickly as possible. We will provide an update as soon as we have more information.
Posted Jul 29, 2024 - 08:26 MDT
This incident affected: United States (Suralink Web Application).