Slow Response Time - US Region

Incident Report for Suralink

Resolved

We have resolved the issue that was causing slow response times and preventing some pages from loading in the application.
Posted Jan 29, 2025 - 18:53 MST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 29, 2025 - 18:15 MST

Identified

We have identified the issue that is causing slow response times and preventing some pages from loading in the application. Our engineers are working towards a resolution.
Posted Jan 29, 2025 - 18:09 MST

Investigating

We are experiencing slow response times and login issues in the Suralink web application in the US region. Our engineering teams are actively working to resolve the issue as quickly as possible. We will provide an update as soon as we have more information.
Posted Jan 29, 2025 - 17:49 MST
This incident affected: United States (Suralink Web Application).