Some client users are unable to upload files or view comments - US Region

Incident Report for Suralink

Resolved

This incident has been resolved.
Posted Jan 29, 2026 - 11:35 MST

Monitoring

A fix for the issue that was preventing some client users from uploading files and viewing comments has been implemented, and we are monitoring to ensure full resolution.
Posted Jan 29, 2026 - 11:12 MST

Investigating

We are investigating an issue with the Suralink web application affecting a small number of client users, where files cannot be uploaded, and comments/history cannot be viewed. Our engineering teams are actively working to resolve the issue as quickly as possible, and we will provide an update as soon as we have more information.
Posted Jan 29, 2026 - 10:28 MST
This incident affected: United States (File Uploads and Downloads, Request List (Engagements)).