Secure File Sharing Outlook Add-in & Workpaper Suite access issues

Incident Report for Suralink

Resolved

The incident with the downstream provider has been resolved, and full functionality of the Secure File Sharing and Workpaper Suite add-ins has been restored.
Posted Oct 29, 2025 - 18:33 MDT

Monitoring

The issue preventing users from working with the Secure File Sharing and Workpaper Suite add-ins is in recovery and we're seeing successful activity in both. We will continue to monitor and provide updates.
Posted Oct 29, 2025 - 15:00 MDT

Identified

We are aware of an issue with a downstream provider that is impacting the Secure File Sharing Outlook Add-in and Workpaper Suite Excel Add-in. We will provide an update when we have additional information.
Posted Oct 29, 2025 - 11:47 MDT
This incident affected: United States (Secure File Sharing, Workpaper Suite), Canada (Secure File Sharing, Workpaper Suite), and Europe (Secure File Sharing, Workpaper Suite).