Login Issues - All Regions
Incident Report for Suralink
Resolved
This incident has been resolved.
Posted Mar 28, 2024 - 11:11 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 28, 2024 - 10:54 MDT
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 28, 2024 - 10:23 MDT
Investigating
We are currently investigating an issue that is preventing users from logging in. Our team is working as quickly as possible to resolve this.
Posted Mar 28, 2024 - 10:20 MDT
This incident affected: United States (Suralink Web Application), Canada (Suralink Web Application), and Europe (Suralink Web Application).